のえら

技術備忘とかメモとか.間違いはつっこんでいただきたい所存.

Scalatraとjettyでエラったでござる

Scalatra2.9.2を使おうとしたら怒られたでござる - のえらの続き

とりあえずscalaとscalatraのバージョンあげてリロードしたらサーブレットの処理入ったところでちょいちょいエラーががが。

java.lang.NoSuchMethodError: javax.servlet.http.HttpServletResponse.getStatus()I

とか

java.lang.AbstractMethodError: org.eclipse.jetty.server.Request.getParts()Ljava/util/Collection;

みたいな。

jettyのバージョンあげなきゃなー、と思って最新の9.0.5にしてみたのに、sbt でエラーががが。。

なんぞー、と思って8.1.12にしてみたら大丈夫だった。
わけわからん。