のえら

技術備忘とかメモとか.間違いはつっこんでいただきたい所存.

Scalatra2.9.2を使おうとしたら怒られたでござる

Scalatra 2.9.2 を使おうとしたら akka-actor が見つからないとか怒られた。

[warn]     ::::::::::::::::::::::::::::::::::::::::::::::
[warn]     ::          UNRESOLVED DEPENDENCIES         ::
[warn]     ::::::::::::::::::::::::::::::::::::::::::::::
[warn]     :: com.typesafe.akka#akka-actor;2.0.5: not found
[warn]     ::::::::::::::::::::::::::::::::::::::::::::::
sbt.ResolveException: unresolved dependency: com.typesafe.akka#akka-actor;2.0.5: not found

akka-actor がない・・・だと・・・?
http://mvnrepository.com/artifact/org.scalatra/scalatra_2.9.2/2.2.0 のThis artifact depends on ...を見てみるとScalatraが使っているakka-actorのバージョンが2.0.5なのにリポジトリから消えているのが原因?(リンク切れてるし)
探したら http://repo.typesafe.com/typesafe/releases/com/typesafe/akka/akka-actor/2.0.5/ にいたので https://github.com/scalatra/scalatra-website-examples/issues/2 を参考にresolversを追加した。

resolvers += "Akka Repo" at "http://repo.akka.io/repository"

とりあえず解決したけど、結局 Scalatra2.10 を使うことにしたよ!!