のえら

技術備忘とかメモとか.間違いはつっこんでいただきたい所存.

Ubuntu12.04でShockwave Flashプラグインを更新したかった

元々仕事でしかUbuntu使わないからflashも無効にしてたんだけども、脆弱性ありとかでるともやっとするので更新することに。
しかしFirefoxの「プラグインのチェックと更新」から[今すぐ更新]を押下すると以下のダウンロード形式しか選べない。。


普段Windowsしか使っていない貧弱な私がサクッと選んでサクッと更新できるわけもなく。
師匠に助けていただき更新しました。本当にありがとうございます。


後で調べて自分でできるようにするためのコマンドメモ。

とりあえずYUMをダウンロードして適当なディレクトリに保存。
今回はデスクトップ。

aliendebを生成する。
sudo alien Desktop/adobe-release-i386-1.0-1.noarch.rpm

こんな感じでdebが生成される
adobe-release-i386_1.0-2_all.deb generated

こいつをインストール
sudo dpkg -i adobe-release-i386_1.0-2_all.deb


追記(20140423):
Ubuntuインストール直後にプラグイン自体のインストールを行う手順はここに書いてある
https://wiki.ubuntulinux.jp/UbuntuTips/Application/HowToInstallAdobeFlashPlayer

ってもLinux用の開発終わったらしいし、今後どうするか・・・